תת-רשתות

רשתות של ענן וירטואלי פרטי (VPC) הן משאבים גלובליים. כל רשת VPC מורכבת מטווח אחד או יותר של כתובות IP שנקראות תת-רשתות. תת-רשתות הן משאבים אזוריים, ויש להן טווחי כתובות IP שמשויכים אליהן.

ב- Google Cloud, המונחים רשת משנה ורשת משנה הם מילים נרדפות. המונחים האלה משמשים לסירוגין במסוף Google Cloud , בפקודות של Google Cloud CLI ובמאמרי העזרה של ה-API.

רשתות ורשתות משנה

כדי להשתמש ברשת, היא צריכה לכלול לפחות רשת משנה אחת. רשתות VPC במצב אוטומטי יוצרות רשתות משנה בכל אזור באופן אוטומטי. רשתות VPC במצב מותאם אישית מתחילות ללא רשתות משנה, כך שיש לכם שליטה מלאה על יצירת רשתות משנה. אפשר ליצור יותר מרשת משנה אחת לכל אזור. מידע על ההבדלים בין רשתות VPC במצב אוטומטי לבין רשתות VPC במצב מותאם אישית זמין במאמר בנושא סוגים של רשתות VPC.

כשיוצרים משאב ב- Google Cloud, בוחרים רשת ותת-רשת. לגבי משאבים אחרים מלבד תבניות של מכונות, בוחרים גם תחום או אזור. כשבוחרים אזור, המערכת בוחרת באופן אוטומטי את האזור הראשי שלו. מכיוון שרשתות משנה הן אובייקטים אזוריים, האזור שבוחרים עבור משאב קובע את רשתות המשנה שבהן הוא יכול להשתמש:

  • כשיוצרים מכונה וירטואלית (VM), בוחרים את התחום שבו היא תפעל. אם לא בוחרים רשת למכונה הווירטואלית, נעשה שימוש ברשת ה-VPC שמוגדרת כברירת מחדל, שיש לה רשת משנה בכל אזור. אם בוחרים רשת למכונה הווירטואלית, צריך לבחור רשת שמכילה רשת משנה באזור ההורה של האזור שנבחר.

  • כשיוצרים קבוצה של מופעי מכונה מנוהלים, בוחרים אזור או אזור זמינות, בהתאם לסוג הקבוצה, ותבנית של הגדרות מכונה. תבנית של הגדרות מכונה מגדירה באיזו רשת VPC להשתמש. לכן, כשיוצרים קבוצת מופעי מכונה מנוהלים, צריך לבחור תבנית של הגדרות מכונה עם הגדרה מתאימה. בתבנית צריך לציין רשת VPC שיש לה תת-רשתות באזור או בתחום (zone) שנבחרו. לרשתות VPC במצב אוטומטי תמיד יש רשת משנה בכל אזור.

  • במהלך יצירת אשכול של קונטיינרים ב-Kubernetes, צריך לבחור אזור או תחום (בהתאם לסוג האשכול), רשת ורשת משנה. צריך לבחור רשת משנה שזמינה באזור או בתחום שנבחרו.

סוגים של רשתות משנה

רשתות VPC תומכות ברשתות משנה עם סוגי המערכים הבאים. רשת VPC אחת יכולה להכיל כל שילוב של רשתות משנה כאלה.

סוג הערימה טווחים של רשתות משנה ממשקי רשת תואמים של מכונות וירטואליות
IPv4 בלבד (single-stack) רק טווחי רשתות משנה של IPv4 ממשקים מסוג IPv4 בלבד
‫IPv4 ו-IPv6 (dual-stack) טווחים של רשתות משנה מסוג IPv4 ו-IPv6 ממשקים עם IPv4 בלבד, עם מחסנית כפולה ועם IPv6 בלבד
IPv6 בלבד (single-stack) רק טווחי רשת משנה של IPv6 ממשקים עם IPv6 בלבד

כשיוצרים רשת משנה, מציינים באיזה סוג מחסנית להשתמש. אפשר גם לשנות את סוג ה-stack של רשת משנה בתרחישים הבאים:

רשתות VPC במצב מותאם אישית תומכות ברשתות משנה עם טווחי כתובות IPv6 בלבד. לא ניתן להשתמש בתת-רשתות עם טווחי כתובות IPv6 ברשתות VPC במצב אוטומטי או ברשתות מדור קודם.

כשיוצרים טווח של תת-רשת IPv4, צריך לספק את הפרטים הבאים:

הגדרת רשת משנה הערכים האפשריים פרטים
טווח IPv4 טווח תקין שאתם בוחרים חובה
טווח משני של כתובות IPv4 טווח תקין שאתם בוחרים אופציונלי

כשיוצרים טווח של תת-רשתות IPv6, מציינים את סוג הגישה ואת המקור של כתובות ה-IP:

סוג הגישה סוג הכתובת והמקור
פנימי
(לא ניתן לניתוב באינטרנט)
‫ULAs: מוקצות באופן אוטומטי מתוך טווח ה-ULA של /48 רשת ה-VPC.
אם אתם משתמשים בכתובות IP משלכם (BYOIP), אתם יכולים להשתמש באופן פרטי בכתובות IPv6 GUA משלכם.
חיצוני
(ניתן לניתוב באינטרנט)
GUAs: מוקצות באופן אוטומטי מתוך כתובות IPv6 חיצוניות אזוריות של Google.
אם אתם משתמשים ב-BYOIP, אתם יכולים להשתמש בכתובות GUA משלכם בפורמט IPv6.

מטרות השימוש בתת-רשתות

כשיוצרים תת-רשת, בוחרים מטרה לתת-הרשת:

  • רשתות משנה רגילות (PRIVATE): זהו סוג רשת המשנה שמוגדר כברירת מחדל. משתמשים יוצרים רשתות משנה רגילות, או שהן נוצרות אוטומטית ברשתות VPC במצב אוטומטי, כדי להשתמש בהן עם מכונות וירטואליות. הייעוד מוצג כללא במסוף Google Cloud .
    • ‫Hybrid Subnets הן רשתות משנה רגילות שהוגדרו עם התנהגות שונה של ניתוב (--allow-cidr-routes-overlap). רשתות משנה היברידיות מתרחבות באופן לוגי לרשת מקומית או לרשת מקור, ומאפשרות להעביר עומסי עבודה אל Google Cloudבלי לשנות כתובות IP. אפשר להפעיל או להשבית את הניתוב ההיברידי עבור רשת משנה בכל שלב.
  • תת-רשתות של Private Service Connect (PRIVATE_SERVICE_CONNECT): תת-רשת שמשמשת לפרסום שירות מנוהל באמצעות Private Service Connect.
  • תת-רשתות של שרת proxy בלבד (GLOBAL_MANAGED_PROXY ו-REGIONAL_MANAGED_PROXY): תת-רשת של שרת proxy בלבד שבה משתמשים עם מאזני עומסים מבוססי Envoy ועם Secure Web Proxy.
  • רשתות משנה פרטיות של NAT (PRIVATE_NAT): רשת משנה ששמורה לשימוש כטווח המקור של NAT פרטי.
  • תת-רשתות להעברת קישור בין רשתות VPC שכנות (peering) (PEER_MIGRATION): תת-רשת שמשמשת להעברת שירות של VPC משותף ל-Private Service Connect. אחרי שההעברה תושלם, תוכלו להמיר את רשת המשנה של העברת ה-VPC לרשת משנה רגילה.

ברוב המקרים, אי אפשר לשנות את הגדרת המטרה של רשת משנה אחרי שהיא נוצרה. מידע נוסף זמין במאמר בנושא הפקודה gcloud compute networks subnets update.

מגבלות על מתן שמות לרשתות משנה

יש מגבלות על השמות של רשתות המשנה:

  • בתוך Google Cloud פרויקט, לתת-רשת לא יכול להיות שם זהה לשם של רשת VPC, אלא אם היא חברה ברשת הזו. בפרויקט, שמות רשתות המשנה באותו אזור חייבים להיות ייחודיים. לדוגמה, לרשת בשם production יכולות להיות כמה רשתות משנה שגם נקראות production, כל עוד כל אחת מהרשתות האלה נמצאת באזור ייחודי.

  • אי אפשר לשנות את השם או האזור של רשת משנה אחרי שיוצרים אותה. עם זאת, אפשר למחוק רשת משנה ולהחליף אותה כל עוד לא נעשה בה שימוש במשאבים.

טווחי רשתות משנה של IPv4

לכל תת-רשת מסוג IPv4 בלבד או מסוג dual-stack צריך להיות טווח כתובות IPv4 ראשי. אם המטרה של רשת המשנה היא PRIVATE או NONE, אפשר להשתמש בטווח ה-IPv4 הראשי למטרות הבאות:

לתת-רשתות יכולים להיות באופן אופציונלי טווחים משניים של כתובות IPv4, שאפשר להשתמש בהם רק בטווחים של כתובות IP של כינויים. טווח כתובות IP של כינוי יכול להגיע מטווח ה-IPv4 הראשי או מטווח ה-IPv4 המשני של תת-רשת.

רשתות המשנה של IPv4 לא צריכות ליצור בלוק CIDR רציף מוגדר מראש, אבל אפשר לעשות את זה אם רוצים. לדוגמה, רשתות VPC במצב אוטומטי יוצרות רשתות משנה שמתאימות לטווח IP מוגדר מראש במצב אוטומטי. עם זאת, הטווח הראשי של רשת משנה יכול להיות 10.0.0.0/24, בעוד שהטווח הראשי של רשת משנה אחרת באותה רשת יכול להיות 192.168.0.0/16.

מגבלות על טווחי רשתות משנה של IPv4

יש מגבלות על טווחי רשתות משנה של IPv4:

  • כל טווח IPv4 ראשי או משני לכל תת-הרשתות ברשת VPC חייב להיות בלוק CIDR חוקי וייחודי.

  • מספר טווחי כתובות ה-IP המשניות שאפשר להגדיר מפורט במגבלות לכל רשת.

  • אחרי שיוצרים תת-רשת, אפשר להרחיב את טווח ה-IPv4 הראשי של תת-הרשת, אבל אי אפשר להחליף אותו או לצמצם אותו.

  • אפשר להסיר ולהחליף את טווח כתובות ה-IPv4 המשני של תת-רשת רק אם אף מכונה לא משתמשת בטווח הזה.

  • הגודל המינימלי של טווח ראשי או משני הוא שמונה כתובות IPv4. במילים אחרות, מסכה של רשת משנה הכי ארוכה שבה אפשר להשתמש היא /29.

  • מסכת רשת המשנה הקצרה ביותר שאפשר להשתמש בה היא /4. עם זאת, ברוב /4 טווחי כתובות ה-IP, יש אימותים נוספים שמונעים יצירה של רשת משנה בגודל הזה. לדוגמה, טווח של תת-רשת לא יכול לחפוף לטווח פרטי של IPv4 או לטווח שמור אחר. כדי לצמצם את הסיכוי לבחור טווח לא תקין של רשת משנה, מומלץ להגביל את הגודל המקסימלי של רשת המשנה ל-/8.

  • אי אפשר ליצור טווחים ראשיים ומשניים לתת-רשתות שחופפים לטווח שהוקצה, לטווח ראשי או משני של תת-רשת אחרת באותה רשת, או לטווחים של IPv4 של תת-רשתות ברשתות מקושרות. Google Cloud מונעת יצירה של טווחי תת-רשתות חופפים בתרחישים האלה.

  • Google Cloud יוצר מסלולי רשת משנה תואמים לשני טווחי כתובות ה-IP, הראשי והמשני. ההגדרה של מסלולי רשתות משנה, ולכן גם של טווחי כתובות IP של רשתות משנה, חייבת להיות הכי ספציפית.

  • טווחים של רשתות משנה לא יכולים להיות זהים לטווח מוגבל, צרים ממנו או רחבים ממנו. לדוגמה, 169.0.0.0/8 הוא לא טווח תקין של רשת משנה כי הוא חופף לטווח המקומי של הקישור 169.254.0.0/16 (RFC 3927), שהוא טווח מוגבל.

  • טווחים של רשתות משנה לא יכולים לכלול גם טווח RFC (כפי שמתואר בטבלה הקודמת) וגם טווח כתובות IP ציבוריות שמשמשות לשימוש פרטי. לדוגמה, 172.0.0.0/10 הוא לא טווח תקין של רשת משנה כי הוא כולל גם את טווח כתובות ה-IP הפרטיות 172.16.0.0/12 וגם כתובות IP ציבוריות.

  • טווחים של רשתות משנה לא יכולים לכלול כמה טווחים של RFC. לדוגמה, 192.0.0.0/8 הוא לא טווח תת-רשת תקין כי הוא כולל גם את 192.168.0.0/16 (מ-RFC 1918) וגם את 192.0.0.0/24 (מ-RFC 6890). עם זאת, אפשר ליצור שתי רשתות משנה עם טווחי כתובות ראשיים שונים, אחת עם 192.168.0.0/16 ואחת עם 192.0.0.0/24. אפשר גם להשתמש בשני הטווחים האלה באותה רשת משנה, אם מגדירים את אחד מהם כטווח משני.

טווחים תקינים של כתובות IPv4

טווח כתובות ה-IPv4 הראשי והמשני של תת-רשת הם כתובות IPv4 פנימיות אזוריות. בטבלה הבאה מתוארים טווחים תקינים.

טווח תיאור
טווחי כתובות IPv4 פרטיות
10.0.0.0/8
172.16.0.0/12
192.168.0.0/16

כתובות IP פרטיות RFC 1918

מידע על השימוש ב-172.17.0.0/16 זמין במאמר שיקולים נוספים.

100.64.0.0/10 מרחב כתובות משותף RFC 6598
192.0.0.0/24 הקצאות פרוטוקולים של IETF‏ RFC 6890
‫192.0.2.0/24 (TEST-NET-1)
198.51.100.0/24 (TEST-NET-2)
203.0.113.0/24 (TEST-NET-3)
מאמרי עזרה RFC 5737
192.88.99.0/24 ממסר מ-IPv6 ל-IPv4 (הוצא משימוש) RFC 7526
198.18.0.0/15 בדיקות השוואה RFC 2544
240.0.0.0/4

שמור לשימוש בעתיד (Class E) כמו שמצוין ב-RFC 5735 וב-RFC 1112.

מערכות הפעלה מסוימות לא תומכות בשימוש בטווח הזה, לכן חשוב לוודא שמערכת ההפעלה שלכם תומכת בו לפני שיוצרים רשתות משנה שמשתמשות בטווח הזה.

טווחי כתובות IP ציבוריות לשימוש פרטי
כתובות IPv4 ציבוריות שמשמשות לשימוש פרטי כתובות IPv4 ציבוריות לשימוש פרטי:
  • כתובות IPv4 שאפשר בדרך כלל לנתב באינטרנט, אבל נעשה בהן שימוש פרטי ברשת VPC
  • לא יכול להיות שייך לטווח של רשת משנה אסורה

כשמשתמשים בכתובות האלה כטווחי רשתות משנה, ‫ Google Cloud לא מכריז על המסלולים האלה באינטרנט ולא מנתב אליהם תעבורה מהאינטרנט.

אם ייבאתם כתובות IP ציבוריות ל-Google באמצעות העברת כתובות IP משלכם (BYOIP), טווחי ה-BYOIP וטווחי כתובות ה-IP הציבוריות שמשמשות לשימוש פרטי באותה רשת VPC לא יכולים להיות חופפים.

בקישור בין רשתות VPC שכנות (peering), לא מתבצעת החלפה אוטומטית של מסלולי תת-רשתות לכתובות IP ציבוריות. כברירת מחדל, מסלולי המשנה מיוצאים אוטומטית, אבל צריך להגדיר במפורש את הרשתות המקבילות כדי לייבא אותם ולהשתמש בהם.

טווחים אסורים של רשתות משנה של כתובות IPv4

טווחים אסורים של רשתות משנה כוללים כתובות IP ציבוריות של Google וטווחים שמורים נפוצים של RFC, כמו שמתואר בטבלה הבאה. אי אפשר להשתמש בטווחי הכתובות האלה לטווחי כתובות של רשתות משנה.

טווח תיאור
כתובות IP ציבוריות של שירותים ו-Google APIs, כולל Google Cloud בלוקים של כתובות IP. כתובות ה-IP האלה מופיעות בכתובת https://gstatic.com/ipranges/goog.txt.
199.36.153.4/30
וגם
199.36.153.8/30
כתובות IP וירטואליות ספציפיות לגישה פרטית ל-Google
0.0.0.0/8 הרשת הנוכחית (המקומית) RFC 1122
127.0.0.0/8 מארח מקומי RFC 1122
169.254.0.0/16 קישור מקומי RFC 3927
224.0.0.0/4 Multicast (Class D) RFC 5771
255.255.255.255/32 כתובת יעד של שידור מוגבל RFC 8190 ו-RFC 919

כתובות שלא ניתן להשתמש בהן בטווחים של רשתות משנה של כתובות IPv4

‫Google Cloud משתמש בשתי כתובות ה-IPv4 הראשונות ובשתי כתובות ה-IPv4 האחרונות בכל טווח כתובות IPv4 ראשי של רשת משנה כדי לארח את רשת המשנה.‫Google Cloud מאפשר להשתמש בכל הכתובות בטווחים משניים של כתובות IPv4.

כתובת IPv4 שלא ניתן להשתמש בה תיאור דוגמה
כתובת רשת הכתובת הראשונה בטווח ה-IPv4 הראשי ‫10.1.2.0 מתוך הטווח 10.1.2.0/24
כתובת שער ברירת המחדל הכתובת השנייה בטווח ה-IPv4 הראשי ‫10.1.2.1 מתוך הטווח 10.1.2.0/24
הכתובת הלפני האחרונה הכתובת השנייה מהסוף בטווח ה-IPv4 הראשי

הטווח הזה שמור על ידי Google Cloud לשימוש פוטנציאלי בעתיד.

‫10.1.2.254 מתוך הטווח 10.1.2.0/24
כתובת שידור הכתובת האחרונה בטווח ה-IPv4 הראשי ‫10.1.2.255 מתוך הטווח 10.1.2.0/24

טווחי IPv4 במצב אוטומטי

בטבלה הזו מפורטים טווחי כתובות ה-IPv4 של תת-הרשתות שנוצרו אוטומטית ברשת VPC במצב אוטומטי. טווח כתובות ה-IP של רשתות המשנה האלה מתאים לבלוק ה-CIDR‏ 10.128.0.0/9. רשתות VPC במצב אוטומטי נוצרות עם רשת משנה אחת לכל אזור בזמן היצירה, ומקבלות אוטומטית רשתות משנה חדשות באזורים חדשים. חלקים שלא נעשה בהם שימוש ב-10.128.0.0/9 שמורים לשימוש עתידי ב-Google Cloud .

אזור טווח כתובות IP‏ (CIDR) שער ברירת המחדל כתובות שניתן להשתמש בהן (כולל)
africa-south1 10.218.0.0/20 10.218.0.1 ‫10.218.0.2 עד 10.218.15.253
asia-east1 10.140.0.0/20 10.140.0.1 ‫10.140.0.2 עד 10.140.15.253
‫asia-east2 10.170.0.0/20 10.170.0.1 ‫10.170.0.2 עד 10.170.15.253
‫asia-northeast1 10.146.0.0/20 ‫10.146.0.1 ‫10.146.0.2 עד 10.146.15.253
asia-northeast2 10.174.0.0/20 10.174.0.1 ‫10.174.0.2 עד 10.174.15.253
asia-northeast3 10.178.0.0/20 10.178.0.1 ‫10.178.0.2 עד 10.178.15.253
‫asia-south1 10.160.0.0/20 ‫10.160.0.1 ‫10.160.0.2 עד 10.160.15.253
asia-south2 10.190.0.0/20 10.190.0.1 ‫10.190.0.2 עד 10.190.15.253
asia-southeast1 10.148.0.0/20 10.148.0.1 ‫10.148.0.2 עד 10.148.15.253
‫asia-southeast2 10.184.0.0/20 ‪10.184.0.1 ‫10.184.0.2 עד 10.184.15.253
asia-southeast3 10.232.0.0/20 10.232.0.1 ‫10.232.0.2 עד 10.232.15.253
australia-southeast1 10.152.0.0/20 10.152.0.1 ‫10.152.0.2 עד 10.152.15.253
australia-southeast2 10.192.0.0/20 10.192.0.1 ‫10.192.0.2 עד 10.192.15.253
europe-central2 10.186.0.0/20 10.186.0.1 ‫10.186.0.2 עד 10.186.15.253
europe-north1 10.166.0.0/20 ‫10.166.0.1 ‫10.166.0.2 עד 10.166.15.253
europe-north2 10.226.0.0/20 10.226.0.1 ‫10.226.0.2 עד 10.226.15.253
europe-west1 10.132.0.0/20 10.132.0.1 ‫10.132.0.2 עד 10.132.15.253
europe-west2 10.154.0.0/20 10.154.0.1 ‫10.154.0.2 עד 10.154.15.253
europe-west3 10.156.0.0/20 10.156.0.1 ‫10.156.0.2 עד 10.156.15.253
europe-west4 10.164.0.0/20 ‫10.164.0.1 ‫10.164.0.2 עד 10.164.15.253
europe-west6 10.172.0.0/20 10.172.0.1 ‫10.172.0.2 עד 10.172.15.253
europe-west8 10.198.0.0/20 10.198.0.1 ‫10.198.0.2 עד 10.198.15.253
europe-west9 10.200.0.0/20 10.200.0.1 ‫10.200.0.2 עד 10.200.15.253
europe-west10 10.214.0.0/20 10.214.0.1 ‫10.214.0.2 עד 10.214.15.253
europe-west12 10.210.0.0/20 10.210.0.1 ‫10.210.0.2 עד 10.210.15.253
europe-southwest1 10.204.0.0/20 10.204.0.1 ‫10.204.0.2 עד 10.204.15.253
me-central1 10.212.0.0/20 10.212.0.1 ‫10.212.0.2 עד 10.212.15.253
me-central2 10.216.0.0/20 10.216.0.1 ‫10.216.0.2 עד 10.216.15.253
me-west1 10.208.0.0/20 10.208.0.1 ‫10.208.0.2 עד 10.208.15.253
northamerica-northeast1 10.162.0.0/20 10.162.0.1 ‫10.162.0.2 עד 10.162.15.253
northamerica-northeast2 10.188.0.0/20 10.188.0.1 ‫10.188.0.2 עד 10.188.15.253
northamerica-south1 10.224.0.0/20 10.224.0.1 ‫10.224.0.2 עד 10.224.15.253
southamerica-east1 10.158.0.0/20 10.158.0.1 ‫10.158.0.2 עד 10.158.15.253
southamerica-west1 10.194.0.0/20 10.194.0.1 ‫10.194.0.2 עד 10.194.15.253
us-central1 10.128.0.0/20 10.128.0.1 ‫10.128.0.2 עד 10.128.15.253
us-east1 10.142.0.0/20 ‫10.142.0.1 ‫10.142.0.2 עד 10.142.15.253
us-east4 10.150.0.0/20 ‫10.150.0.1 ‫10.150.0.2 עד 10.150.15.253
us-east5 10.202.0.0/20 ‫10.202.0.1 ‫10.202.0.2 עד 10.202.15.253
us-south1 10.206.0.0/20 10.206.0.1 ‫10.206.0.2 עד 10.206.15.253
us-west1 10.138.0.0/20 ‫10.138.0.1 ‫10.138.0.2 עד 10.138.15.253
us-west2 10.168.0.0/20 10.168.0.1 ‫10.168.0.2 עד 10.168.15.253
us-west3 10.180.0.0/20 10.180.0.1 ‫10.180.0.2 עד 10.180.15.253
us-west4 10.182.0.0/20 10.182.0.1 ‫10.182.0.2 עד 10.182.15.253

שיקולים נוספים

מוודאים שאין התנגשות בין כל טווחי כתובות ה-IPv4 הראשיים והמשניים של רשתות המשנה לבין טווחי כתובות ה-IPv4 שתוכנה שפועלת בתוך המכונות הווירטואליות צריכה להשתמש בהם. חלק ממוצרי Google ומוצרים של צד שלישי משתמשים ב-172.17.0.0/16 לניתוב בתוך מערכת ההפעלה של האורח. לדוגמה, רשת הגישור של Docker שמוגדרת כברירת מחדל משתמשת בטווח הזה. אם אתם מסתמכים על מוצר שמשתמש ב-172.17.0.0/16, אל תשתמשו בו כטווח כתובות IPv4 ראשי ומשני של רשת משנה.

טווחי רשתות משנה של IPv6

כשיוצרים תת-רשת עם טווח כתובות IPv6 או מפעילים IPv6 בתת-רשת קיימת ברשת VPC, בוחרים סוג גישה ל-IPv6 עבור תת-הרשת. סוג הגישה ל-IPv6 קובע אם רשת המשנה מוגדרת עם כתובות IPv6 פנימיות או עם כתובות IPv6 חיצוניות. כשמפעילים IPv6 עבור תת-רשת קיימת, אפשר גם לבחור את מסלול שירות הרשת של תת-הרשת הזו. מידע נוסף על השימוש במסלולי שירות רשת זמין במאמר סקירה כללית על מסלולי שירות רשת. כדי לבחור מסלול שירות רשת של תת-רשת, קראו את המאמר בנושא בחירת מסלול שירות רשת של תת-רשת. שימו לב: אי אפשר לשנות את מסלול שירותי הרשת של רשת משנה אחרי שמגדירים אותו או אחרי שהוא יורש את המסלול מהפרויקט. Google Cloud

  • כתובות IPv6 פנימיות משמשות לתקשורת בין מכונות וירטואליות ברשתות VPC. אפשר לנתב אותם רק במסגרת רשתות VPC, ואי אפשר לנתב אותם לאינטרנט.

  • אפשר להשתמש בכתובות IPv6 חיצוניות לתקשורת בין מכונות וירטואליות ברשתות VPC, והן ניתנות לניתוב באינטרנט.

אם ממשק של מכונה וירטואלית מחובר לרשת משנה עם טווח כתובות IPv6, אפשר להגדיר כתובות IPv6 במכונה הווירטואלית. סוג הגישה ל-IPv6 של רשת המשנה קובע אם למכונה הווירטואלית מוקצית כתובת IPv6 פנימית או כתובת IPv6 חיצונית.

מפרט IPv6

רשתות משנה עם טווחי כתובות IPv6 זמינות בכל האזורים, והן תומכות בטווחי כתובות IPv6 חיצוניים ופנימיים.

לרשתות משנה עם טווחי כתובות IPv6 יש את המגבלות הבאות:

  • אי אפשר לשנות את סוג הגישה ל-IPv6 (פנימית או חיצונית) של רשת משנה.

  • אי אפשר לשנות רשת משנה עם כתובות IPv4 ו-IPv6 ל-IPv4 בלבד אם סוג הגישה ל-IPv6 הוא פנימי.

  • אי אפשר לשנות רשת משנה עם פרוטוקול כפול או עם IPv4 בלבד ל-IPv6 בלבד. לעומת זאת, אי אפשר לשנות רשת משנה עם IPv6 בלבד לרשת משנה עם IPv4 בלבד או לרשת משנה עם מחסנית כפולה.

מפרטים חיצוניים של IPv6

טווחים של כתובות IPv6 חיצוניות הם כתובות גלובליות של שידור יחיד (GUA). כתובות IPv6 חיצוניות זמינות במסלול הרגיל (בגרסת טרום-השקה) ובמסלול הפרימיום. מידע נוסף על מסלולי שירות רשת זמין במאמר סקירה כללית על מסלולי שירות רשת.

טווח כתובות ה-IPv6 החיצוניות של תת-רשת מגיע מאחד מהמקורות הבאים:

המשאבים שיכולים להשתמש בטווח כתובות IPv6 חיצוניות של תת-רשת תלויים במקור של טווח הכתובות.

  • אפשר להשתמש בטווחים של תת-רשתות IPv6 חיצוניות שסופקו על ידי BYOIP רק לטווחים של כתובות /96 IPv6 חיצוניות של ממשקי רשת של מכונות וירטואליות. אתם יכולים להקצות כתובות IPv6 BYOIP לכללי העברה, אבל הכתובות האלה לא מהוות חלק מתת-רשת.

  • אפשר להשתמש בטווחים של תת-רשתות IPv6 חיצוניות שסופקו על ידי Google באופן הבא:

    צריך ליצור את המשאבים שלמעלה באמצעות כתובות IP מהטווח המתאים /65 שהוקצה למשאב. אחרת, Google Cloudמחזירה שגיאה.

    לדוגמה, נניח שטווח כתובות ה-IPv6 החיצוניות של תת-רשת הוא 2001:db8:981:4:0:0:0:0/64:

    • טווח ה-/65 שהוקצה לשימוש על ידי מכונות וירטואליות הוא 2001:db8:981:4:0:0:0:0/65.
    • טווח ה-/65 שהוקצה לשימוש על ידי Cloud Load Balancing הוא 2001:db8:981:4:8000:0.

כדי לבדוק את המקור של טווח כתובות ה-IPv6 החיצוניות של תת-רשת, אפשר לתאר את תת-הרשת. אם הנכס ipv6AccessType הוא EXTERNAL והנכס ipCollection לא ריק, רשת המשנה נוצרה עם טווח כתובות IPv6 BYOIP.

אפשר להקצות טווחים של כתובות IPv6 /96 חיצוניות בדרכים הבאות:

  • אם לא מציינים, Google Cloud מוקצה באופן אוטומטי טווח כתובות IPv6 חיצוניות ארעיות /96.
  • אתם יכולים לציין טווח כתובות IPv6 חיצוניות אזוריות סטטיות שמורות /96. אם שומרים טווח כתובות IPv6 חיצוניות אזוריות סטטיות /96 מטווח כתובות משנה של IPv6 שסופק על ידי BYOIP, צריך לציין VM כסוג נקודת הקצה.

  • למכונות וירטואליות ולכללי העברה אזוריים, אפשר לציין טווח מותאם אישית של כתובות IPv6 חיצוניות זמניות /96.

מפרטים פנימיים של IPv6

אי אפשר לנתב באופן ציבורי טווחים של תת-רשתות פנימיות של IPv6, ואי אפשר להגיע אליהם מהאינטרנט. טווח כתובות ה-IPv6 הפנימי של תת-רשת מגיע מאחד מהמקורות הבאים:

  • כברירת מחדל: Google Cloud המערכת מקצה טווח /64 שלא נמצא בשימוש מתוך טווח ה-ULA של רשת ה-VPC ‏‎ /48.

  • אם אתם משתמשים ב-BYOIP: אתם יכולים להקצות טווח של /64 GUA מתוך קידומת משנה של BYOIP. למרות שכתובות GUA הן בדרך כלל כתובות ציבוריות, בהגדרה הזו הן משמשות ככתובות פרטיות ופועלות באותו אופן כמו כתובות ULA שהוקצו על ידיGoogle Cloud.

כדי להשתמש בכתובות ULA שסופקו על ידי Google כטווח של רשתות משנה פנימיות של IPv6, קודם צריך להקצות טווח ULA של /48 לרשת ה-VPC. כשמקצים טווח ULA פנימי לתת-רשת,מערכת Google Cloud בוחרת באופן אוטומטי טווח /64 IPv6 לא בשימוש מתוך טווח ה-/48ULA IPv6 של רשת ה-VPC. אם רוצים למנוע הקצאה של טווח ULA ספציפי ברשת VPC, אפשר ליצור משאב של טווח פנימי לחלק השמור של טווח כתובות ה-IPv6.

כשמקצים טווח כתובות IPv6 מסוג /48 ULA לרשת VPC, חשוב לזכור את הנקודות הבאות:

  • טווח ה-/48 ULA IPv6 של כל רשת VPC צריך להיות ייחודי עם Google Cloud. כך נמנעת האפשרות של חפיפה בין טווחי רשתות משנה של IPv6 כשמשתמשים בקישור בין רשתות שכנות (peering) של VPC.

  • אפשר לאפשר ל- Google Cloud להקצות באופן אוטומטי את טווח כתובות ה-IPv6 של /48 ULA ברשת ה-VPC, או לספק טווח כתובות IPv6 של /48ULA לשימוש. אם טווח כתובות ה-IPv6 של /48ULA שסיפקתם כבר נמצא בשימוש ברשת Google Cloud VPC אחרת, תוצג לכם שגיאה.

  • האפשרות לספק טווח של כתובות /48 IPv6 מסוג ULA שימושית כדי למנוע התנגשויות בין רשת ה-VPC לבין רשתות מקומיות מחוברות או רשתות אצל ספקי ענן אחרים.

  • אחרי שמקצים לרשת VPC טווח כתובות IPv6 מסוג /48 ULA, אי אפשר להסיר או לשנות את טווח כתובות ה-IPv6 מסוג /48 ULA.

אפשר להשתמש בטווחים של כתובות IPv6 בתת-רשת פנימית /64 לצרכים הבאים, בלי קשר לסוג הכתובות:

אפשר להקצות טווחים פנימיים של כתובות /96 IPv6 בדרכים הבאות:

  • אם לא מציינים טווח,המערכת Google Cloud מקצה אוטומטית טווח כתובות IPv6 פנימיות ארעיות /96.
  • אפשר לציין טווח כתובות IPv6 פנימיות אזוריות סטטיות שמורות /96.
  • עבור מכונות וירטואליות וכללי העברה אזוריים, אפשר לציין טווח מותאם אישית של כתובות IPv6 פנימיות זמניות /96.

הקצאת טווח IPv6

טווחים של כתובות IPv6 מוקצים לרשתות, לתת-רשתות, למכונות וירטואליות (VM) ולכללי העברה.

סוג המשאב גודל הטווח פרטים
רשת VPC /48

כדי להפעיל טווח ULA פנימי ברשת משנה, צריך קודם להקצות טווח ULA פנימי של IPv6 לרשת ה-VPC.

טווח ULA של /48 מתוך fd20::/20 מוקצה לרשת. כל טווחי רשתות המשנה הפנימיות של ULA ברשת מוקצים מהטווח /48 הזה.

אפשר להקצות את טווח /48 באופן אוטומטי, או לבחור טווח ספציפי מתוך fd20::/20.

תת-רשת /64

ההגדרה של סוג הגישה ל-IPv6 קובעת אם כתובות ה-IPv6 הן פנימיות או חיצוניות.

לתת-רשת יכולות להיות כתובות IPv6 פנימיות או חיצוניות, אבל לא שילוב של שתיהן.

כשמפעילים את IPv6, קורים הדברים הבאים:

  • אם מפעילים IPv6 פנימי ברשת משנה, מוקצה טווח של כתובות ULA פנימיות מתוך הטווח /48 של רשת ה-VPC./64
  • אם מפעילים IPv6 חיצוני ברשת משנה, /64 טווח של כתובות GUA חיצוניות מוקצה באופן אוטומטי על ידי Google Cloud. Google Cloud מקצה כל מחצית של טווח /64למטרה ספציפית, באופן הבא:
    • הטווח /65 שמייצג את המחצית הראשונה של רשת המשנה מוקצה למכונות וירטואליות.
    • הטווח /65 שמייצג את החצי השני של רשת המשנה מוקצה ל-Cloud Load Balancing.
  • אפשרות אחרת היא להקצות טווח של רשתות משנה פנימיות או חיצוניות מקידומת משנה של IPv6 שהובאה באמצעות BYOIP. מידע נוסף זמין במאמר בנושא שימוש בכתובת IP משלכם.
מופע ב-VM /96

כשמגדירים במכונה וירטואלית ממשק רשת עם תמיכה כפולה ב-IPv4 ו-IPv6 או רק ב-IPv6, לממשק מוקצה טווח כתובות IP‏ /96 מרשת המשנה של הממשק. Google Cloud מספק את כתובת ה-IP הראשונה בטווח /96 באמצעות DHCPv6.

האם ממשק רשת של מכונה וירטואלית משתמש בטווח כתובות IPv6 פנימי או חיצוני/96 תלוי בסוג הגישה ל-IPv6 של רשת המשנה של הממשק.

כלל העברה למאזן עומסי רשת פנימי להעברת סיגנל ללא שינוי, למאזן עומסי רשת אזורי חיצוני להעברת סיגנל ללא שינוי או להעברת פרוטוקולים ‫/96 או שצוין על ידי קידומת משנה של BYOIP

טווח כתובות ה-IPv6 של כלל העברה להעברת פרוטוקול פנימית או למאזן עומסי רשת פנימי להעברת סיגנל ללא שינוי הוא טווח כתובות IP פנימיות /96 מתוך טווח כתובות ה-IPv6 הפנימי של תת-הרשת. אפשר לבחור באופן אוטומטי טווחי כתובות /96 IP פנימיות Google Cloud או להזמין טווח כתובות IPv6 פנימיות אזוריות סטטיות /96.

טווח כתובות ה-IPv6 של כלל העברה להעברת פרוטוקולים חיצונית או של מאזן עומסי רשת אזורי חיצוני להעברת סיגנל ללא שינוי הוא אחד מהבאים:

  • אם משתמשים בכתובות IPv6 חיצוניות שסופקו על ידי Google, טווח כתובות ה-IPv6 הוא טווח כתובות חיצוני /96 שנבחר באופן אוטומטי על ידי Google Cloud מתוך טווח כתובות ה-IPv6 החיצוני של תת-הרשת.
  • אם משתמשים בכתובות IPv6 חיצוניות של BYOIP, טווח כתובות ה-IPv6 מגיע מקידומת משנה של כתובת IPv6 של BYOIP במצב יצירת כלל העברה. הגודל של טווח IPv6 נקבע לפי אורך הקידומת שניתן להקצאה של קידומת המשנה.

כתובות שלא ניתן להשתמש בהן בטווחים של רשתות משנה של IPv6

אי אפשר לציין באופן ידני את הטווח הראשון והאחרון של טווח /96 פנימי של רשת משנה/64 כי Google Cloud שומרת את הטווח הראשון והאחרון של טווח /96 פנימי של רשת משנה/64 לשימוש המערכת. אתם יכולים לציין באופן ידני כל טווח /96 IPv6 תקף מתוך טווח /64 פנימי של רשת המשנה שיוקצה לממשקי רשת של מכונה וירטואלית.

כתובת IPv6 שלא ניתן להשתמש בה תיאור דוגמה
הטווח הראשון /96 מתוך טווח ה-IPv6 הפנימי של תת-הרשת /64 שמור לשימוש המערכת ‫fd20:db8::/96 מתוך הטווח fd20:db8::/64
הטווח האחרון /96 מתוך טווח ה-IPv6 הפנימי של תת-הרשת /64 שמור לשימוש המערכת ‫fd20:db8:0:0:ffff:ffff::/96 מתוך הטווח fd20:db8::/64

המאמרים הבאים

נסו בעצמכם

אנחנו ממליצים למשתמשים חדשים ב-Google Cloud ליצור חשבון כדי שיוכלו להעריך את הביצועים של Cloud NAT בתרחישים מהעולם האמיתי. לקוחות חדשים מקבלים בחינם גם קרדיט בשווי 300 $להרצה, לבדיקה ולפריסה של עומסי העבודה.

להתנסות ב-Cloud NAT בחינם