CANNOT_LOAD_STATE_STORE error condition

SQLSTATE: 58030

An error occurred during loading state.

AUTO_SNAPSHOT_REPAIR_FAILED

Failed to load snapshot version for state store . An attempt to auto repair using snapshot versions () out of available snapshots () also failed.

CANNOT_FIND_BASE_SNAPSHOT_CHECKPOINT

Cannot find a base snapshot checkpoint with lineage: .

CANNOT_READ_CHECKPOINT

Cannot read RocksDB checkpoint metadata. Expected , but found .

CANNOT_READ_DELTA_FILE_KEY_SIZE

Error reading delta file of : key size cannot be .

CANNOT_READ_DELTA_FILE_NOT_EXISTS

Error reading delta file of : does not exist.

CANNOT_READ_MISSING_SNAPSHOT_FILE

Error reading snapshot file of : does not exist.

CANNOT_READ_SNAPSHOT_FILE_KEY_SIZE

Error reading snapshot file of : key size cannot be .

CANNOT_READ_SNAPSHOT_FILE_VALUE_SIZE

Error reading snapshot file of : value size cannot be .

CANNOT_READ_STREAMING_STATE_FILE

Error reading streaming state file of : does not exist. If the stream job is restarted with a new or updated state operation, please create a new checkpoint location or clear the existing checkpoint location.

CANNOT_WRITE_STREAMING_STATE_FILE

Failed to write the streaming state store file because the checkpoint location is read-only or the identity lacks write permission. Ensure the checkpoint location is writable. Error message:

CHECKPOINT_FILE_CHECKSUM_VERIFICATION_FAILED

CONFIGURATION_MISMATCH

The state store failed to load successfully because state store configuration doesn't match with configuration in checkpoint. Error message:

CONNECTION_POOL_SHUT_DOWN

Failed to load the state store with ID '' from provider ''. Retrieved error message:

CONNECTION_REFUSED

Failed to load the state store with ID from provider due to a connection refused error. Error message:

FAILED_TO_GET_CHANGELOG_WRITER

Failed to get the changelog writer for state store at version .

HDFS_STORE_PROVIDER_OUT_OF_MEMORY

Could not load HDFS state store with id because of an out of memory exception.

INCORRECT_NUMBER_FORMAT

The state store failed to load successfully. Retrieved error message:

INVALID_CHANGE_LOG_READER_VERSION

The change log reader version cannot be . The checkpoint probably is from a future Spark version, please upgrade your Spark.

INVALID_CHANGE_LOG_WRITER_VERSION

The change log writer version cannot be .

INVALID_CHECKPOINT_LINEAGE

Invalid checkpoint lineage: .

KEY_ROW_FORMAT_VALIDATION_FAILURE

LOCAL_DISK_ERROR

Failed to load the state store with ID from provider due to local disk error. A common reason for this could be running out of local disk space on the executor.

ROCKSDB_STORE_PROVIDER_OUT_OF_MEMORY

Could not load RocksDB state store with id because of an out of memory exception.

ROW_CHECKSUM_VERIFICATION_FAILED

SNAPSHOT_PARTITION_ID_NOT_FOUND

Partition id not found for state of operator at .

UNCATEGORIZED

UNEXPECTED_FILE_SIZE

Copied to , expected bytes, found bytes.

UNEXPECTED_VERSION

Version cannot be because it is less than 0.

UNRELEASED_THREAD_ERROR

: RocksDB instance could not be acquired by for operationType= as it was not released by after ms.

Thread holding the lock has trace:

VALUE_ROW_FORMAT_VALIDATION_FAILURE

VERSIONID_MISMATCH

Version Id of the RocksDB local file doesn't match the one created in version .