Skip to content

/var dataset requires legacy mount on systemd based distros. #3768

Description

@gotwf

When separating out /var and NOT using legacy mounts, journald writes to /var before zfs has initiated/mounted it. Hence, zfs will subsequently be unable to mount /var, as it now contains existing data. Note that I've not tested this very thoroughly, and it has been some years since I used zfs (so maybe I'm out in left field here....) but that sure looks to be what is happening.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions