انتقل إلى المحتوى

لغة تأشير النص الترابطي

من ويكيبيديا، الموسوعة الحرة
لغة تأشير النص الترابطي
الشعار
امتداد الملف
  • .html
  • .htm
صيغة وسائط الإنترنت
text/html
نوع الصيغة
المطور
أول إصدار
1993؛ منذ 33 سنة (1993)
امتدّ من
امتدّ لـ
المعايير
15445[1] عدل القيمة على Wikidata
صيغة مفتوحة?
نعم
موقع الويب

لغة تأشير النص الترابطي[2] (الإنجليزية: HyperText Markup Language) (اختصار HTML)، هي لغة توصيف تستخدم في إنشاء وتصميم صفحات ومواقع الويب، وتعتبر هذه اللّغة من أقدم اللّغات وأوسعها استخداما في تصميم صفحات الويب. HTML هيكل صفحة الويب وتعطي متصفّح الإنترنت وصفا لكيفيّة عرضه لمحتوياتها، يمكن أن تساعده تقنيات مثل أوراق الأنماط المتتالية (CSS) ولغات البرمجة النصية مثل جافا سكريبت تستقبل متصفحات الويب مستندات HTML من خادم الويب أو من نظام الملفات وتعرضها، ووظيفة لغة HTML هي وصف بنية صفحات الويب هيكليًا.

العناصر في HTML هي اللبنة الأساسية لبناء مستندات HTML، إذ نستطيع عبرها إضافة الصور والكائنات التفاعلية مثل النماذج أو ملفات الفيديو والصوت؛ وتستطيع أيضًا إنشاء مستندات منظمة عبر استخدام وسوم للتصريح عن الفقرات والعناوين والروابط والاقتباسات والجداول وغيرها.

يمكن للغة HTML أن تُضمِّن برامجَ مكتوبةٍ بلغات مثل جافا سكريبت لتعديل سلوك ومحتوى صفحات الويب؛ وإضافة شيفرات أوراق الأنماط المتتالية CSS تؤدي إلى تعريف شكل وتخطيط المحتوى.

تاريخها

[عدل | عدل المصدر]
الفيزيائي تيم بيرنرز لي

الأصول

[عدل | عدل المصدر]
شكل صفحة البرمجة

في عام 1980، قام الفيزيائي تيم بيرنرز لي والذي كان عاملاً في المؤسسة الأوروبية للأبحاث النووية سيرن باقتراح وإعداد نموذج بدئي لنظام يمكن باحثي سيرن من استخدام ومشاركة المستندات. وفي عام 1989 قام بكتابة مذكرة[3] يقترح فيها نظام نص فائق hypertext مبني على الإنترنت، وقام بوصف لغة HTML وبكتابة برامج المزود والمتصفح في أواخر عام 1990.

كان أول وصف للجمهور من الاتش تي ام ال وثيقة تسمى علامات الاتش تي ام ال ذكر لأول مرة على شبكة الإنترنت عن طريق بيرنرز لي في أواخر عام 1991. فهو يصف 18 من العناصر الأولى التي تتألف منها، نسبياً التصميم بسيط في الاتش تي ام ال باستثناء علامة الارتباط التشعبي، هذه تأثرت بقوة في (الاس جي ام ال كويد)، أسست ال (الاس جي ام ال ) على شكل وثائق في منزل سيرن. أحد عشر من هذه العناصر لا تزال موجودة في الاتش تي ام ال.

لغة توصيف النص التشعبي هي لغة العلامات التي تستخدم متصفحات الويب لتفسير وتأليف النص والصور وغيرها من المواد في صفحات الويب المرئية أو المسموعة. يتم تعريف وتوصيف الخصائص الافتراضية لكل بند من الاتش تي ام ال في المتصفح ,وهذه الخصائص يمكن تغيرها أو تحسينها بواسطة استخدام مصمم صفحة ويب اضافية من الاسي اس اس. عُثر على العديد من عناصر النص في عام 1988 (أي اس أو ) تقرير التقنية (تي ار 9537) تقنيات لاستخدام (الاس جي ام ال ) الذي يغطي بدوره ملامح اللغات تنسيق النص في وقت مبكر مثل تلك المستخدمة من قبل الأمر الجريان السطحي وضعت في 1960s في وقت مبكر ل CTSS (التوقيت متوافق نظام تقاسم ) نظام التشغيل : وقد استمدت هذه الأوامر التنسيق من الأوامر المستخدمة من قبل عمال التجميع على تنسيق المستندات يدويا. ومع ذلك، يستند مفهوم SGML من معمم العلامات على عناصر ( نطاقات متداخلة مع سمات المشروح ) بدلاً من مجرد آثار الطباعة، مع أيضاً الفصل بين هيكل والعلامات، وقد تم HTML انتقلت تدريجيا في هذا الاتجاه مع CSS. بيرنرز لي يعتبر تطبيق HTML من SGML تم تعريفه رسميا على هذا النحو من قبل فريق عمل هندسة الإنترنت (IETF ) مع منتصف عام 1993 نشر أول اقتراح ل مواصفات HTML: «لغة توصيف النص التشعبي (HTML )» إنترنت مشروع من قبل بيرنرز لي و دان كونولي، الذي تضمنت نوع الوثيقة SGML تعريف لتعريف النحوي.

الجدول الزمني للإصدارات

[عدل | عدل المصدر]
تم نشر HTML 2.0 باسم RFC   [rfc:1866 1866] . RFCs إضافية القدرات المضافة:
  • 25 نوفمبر 1995: RFC 1867 (تحميل ملف مستند إلى النموذج)
  • مايو 1996: RFC 1942 (الجداول)
  • أغسطس 1996: RFC 1980 (خرائط صور من جانب العميل)
  • يناير 1997: RFC 2070 ( التدويل )
تم نشر HTML 3.2 [4] رابطة الشبكة العالمية. كانت أول نسخة تم تطويرها وتوحيدها حصريًا بواسطة رابطة الشبكة العالمية، حيث أغلق IETF فريق عمل HTML في 12 سبتمبر 1996.[5]
في البداية ، اسم "Wilbur" ، [6] HTML 3.2 أسقطت صيغ الرياضيات تمامًا، وصالح التداخل بين ملحقات الملكية المختلفة واعتمدت معظم علامات تمييز نتسكيب المرئية. تم حذف عنصر وميض نتسكيب ومايكروسوفت بسبب اتفاق متبادل بين الشركتين.[7] لم يتم توصيف العلامات الخاصة بالصيغ الرياضية المشابهة لتلك الموجودة في HTML حتى 14 شهرًا في ماث إم إل.
تم نشر HTML 4.0 [8] كتوصية من رابطة الشبكة العالمية. إنه يوفر ثلاثة أشكال:
  • صارمة ، حيث تحظر العناصر المهملة
  • انتقالي ، حيث يسمح للعناصر المهملة
  • مجموعة الإطارات ، والتي يُسمح فيها في الغالب بالعناصر ذات الصلة بالإطار فقط.
في البداية ، أطلق عليها اسم "Cougar" ، [6] اعتمد HTML 4.0 العديد من أنواع العناصر والسمات الخاصة بالمتصفح ، ولكن في الوقت نفسه سعى إلى التخلص التدريجي من ميزات العلامات البصرية لـ Netscape عن طريق وضع علامة عليها على أنها متقادمة لصالح أوراق الأنماط. HTML 4 هو تطبيق SGML يتوافق مع ISO 8879   - SGML.[9]
24 أبريل 1998
تم إعادة إصدار HTML 4.0 [10] مع تعديلات بسيطة دون زيادة رقم الإصدار.
24 ديسمبر 1999
تم نشر HTML 4.01 [11] كتوصية W3C. يوفر نفس الأشكال الثلاثة مثل HTML 4.0 وقد تم نشر آخر خطأ له في 12 مايو 2001.
مايو 2000
تم نشر ISO / IEC 15445: 2000 [12][13] («ISO HTML» ، بناءً على HTML 4.01 Strict) كمعيار دولي ISO / IEC. في ISO ، تندرج هذه المواصفة القياسية في مجال ISO / IEC JTC1 / SC34 (اللجنة الفنية المشتركة 1 ISO / IEC ، اللجنة الفرعية 34   - وصف الوثيقة ومعالجة اللغات).[12]
بعد HTML 4.01 ، لم يكن هناك إصدار جديد من HTML لسنوات عديدة لأن تطوير لغة XHTML المتوازية المستندة إلى XML احتلت مجموعة عمل HTML في W3C خلال أوائل ومنتصف الألفية
28 أكتوبر 2014
تم نشر HTML5 [14] كتوصية W3C.[15]
1 نوفمبر 2016
تم نشر HTML 5.1 [16] كتوصية W3C.[17][18]
14 ديسمبر 2017
تم نشر HTML 5.2 [19] كتوصية W3C.[20][21]

HTML Living Standard

[عدل | عدل المصدر]

بنية مستندات HTML

[عدل | عدل المصدر]

تتألف صفحات HTML من عناصر، والتي تتألف عادةً من وسم بداية ووسم نهاية، ويكون بينهما محتوى نصي عادةً؛ ويمكن أن نضع في وسم البداية بعض الخاصيات التي تُغيّر من سلوك العنصر أو تؤدي إلى ضبطه. لاحظ أنَّ بعض العناصر يمكن أن تتشعب داخل بعضها بعضًا. الأقسام الأساسية للعناصر هي:

  • وسم البداية: وهو يحتوي على اسم العنصر، موضوعًا ضمن قوسين على شكل زاوية، وقد يلي الاسم الخاصيات التي تؤثر عليه. مثلًا

    .

  • وسم النهاية: وهو يحتوي على اسم العنصر أيضًا مسبوقًا بخطٍ مائل قبله للإشارة إلى نهاية العنصر؛ لاحظ أنَّ نسيان وسم النهاية قد يسبب أخطاءً في بعض الأحيان، لذا خذ حذرك وتذكره. مثلًا:

    .

  • المحتوى: وهو موجودٌ بين وسمَي البداية والنهاية، ويُمثِّل في معظم الأحيان محتوى العنصر.
  • العنصر: هو وسم البداية ووسم النهاية إضافةً إلى المحتوى.
_____ وسم النهاية _____   وسم البداية
| |                 |  |
<p>paragraph contentp>
  |__محتوى العنصر___|

قد تحتوي العناصر على خاصيات، وهذه الخاصيات بعضها اختياري وبعضها إجباري، وهنالك خاصيات تسمى بالخاصيات العامة والتي يمكن استخدامها على جميع العناصر. تتألف الخاصية في أغلب الحالات من اسم الخاصية ثم قيمة تليها.

_____ وسم النهاية _____                 وسم البداية
| |                               |  |
<p class="light">paragraph contentp>
   |__محتوى العنصر__|__الخاصيات___|

يبدأ المثال الآتي بالتصريح عن نوع المستند (DOCTYPE) الخاص بإصدار HTML5، ثم يُعرِّف العنصر الجذر الذي يُشير إلى بدء مستند HTML. يحتوي العنصر على عنصرين هما العنصر و ؛ أما العنصر فيحتوي على البيانات الوصفية التي تصف المستند مثل العنصر </code> الذي ضبط عنوان الصفحة والعنصر <code id="mw-g"><meta></code> الذي ضبط هنا ترميز محارف المستند والعنصر <code id="mw-w"><link></code> الذي أشار إلى مستند CSS والعنصر <code id="mw_A"><script></code> الذي أشار إلى شيفرة JavaScript. وأما العنصر <code id="mw_Q"><body></code> فيمثِّل محتوى الصفحة نفسها، كالصور (العنصر <code id="mw_g"><img></code>) والفقرات (العنصر <code id="mw_w"><span typeof="mw:Nowiki" id="mwAQA"><p></span></code>) وغير ذلك. لاحظ كيف ينتهي كل قسم من أقسام المستند بوسوم الإغلاق المناسبة.</p><div class="mw-highlight mw-highlight-lang-html mw-content-ltr" dir="ltr" typeof="mw:Extension/syntaxhighlight" about="#mwt82" id="mwAQE" data-mw="{"name":"syntaxhighlight","attrs":{"lang":"html"},"body":{"extsrc":"\n<!DOCTYPE html>\n<html>\n <head>\n <meta charset=\"utf-8\">\n <title>Page Title\n \n \n \n \n \"My\n

Hello World!

\n \n\n"}}">

<html>
  <head>
    <meta charset="utf-8">
    <title>Page Titletitle>
    <link href="style.css" rel="stylesheet">
    <script src="javascript.js">script>
  head>
  <body>
    <img src="images/logo.png" alt="My Logo">
    <p>Hello World!p>
  body>
html>

نُظِّم هذا الدليل بتخصيص صفحة لكل عنصر من عناصر HTML، أي يمكن زيارة الصفحة HTML/tagname للحصول على معلومات حول العنصر . فللحصول على معلومات عن العنصر نزور الصفحة HTML/img، ولمعرفة تفاصيل العنصر

نزور الصفحة HTML/table. أما حقول النماذج فهي موجودة ضمن صفحات فرعية في صفحة HTML/input(مثلًا: الصفحة HTML/input/email للحقل ).

تحتوي هذه الصفحة على قائمة بعناصر HTML، منظمةً حسب وظيفتها ليسهل عليك الوصول إلى مبتغاك.

العنصر الجذر

[عدل | عدل المصدر]
العنصر الوصف
تمثيل العنصر الرئيسي في مستندات HTML، ويُشار إليه أحيانًا باسم «العنصر الجذر» (root element). يجب أن تكون جميع العناصر الأخرى في المستند سليلةً (descendants، أي أبناء مباشرين وغير مباشرين) له ولهذا العنصر خاصية هي dir وتأخذ احدى القيمتين rtl او ltr.[22]


البيانات الوصفية

[عدل | عدل المصدر]

تحتوي البيانات الوصفية على معلومات عن الصفحة، التي تتضمن المعلومات حول الأنماط (styles) والسكربتات، والبيانات المُساعدة للبرمجيات (مثل محركات البحث والمتصفحات ...إلخ.) التي تستخدم الصفحة أو تعرضها.

العنصر الوصف
تحديد أساس روابط URL لجميع الروابط النسبية (relative URLs) الموجودة في المستند. لا يجوز استخدام أكثر من عنصر في المستند.
توفير معلوماتٍ عامةً عن المستند (أي بيانات وصفية)، بما في ذلك عنوان المستند وروابط إلى السكربتات الموجودة فيها وصفحات الأنماط.
تحديد العلاقات بين المستند الحالي وبين مورد خارجي (external resource)؛ من استخدامات هذا الوسم تتضمن تعريف علاقة بين الصفحات للتنقل بينها، بيد أنَّ أكثر استخدامات هذا العنصر شيوعًا هو تضمين صفحات الأنماط.
تمثيل البيانات الوصفية التي لا يمكن تمثيلها باستخدام عناصر HTML المتعلقة بالبيانات الوصفية مثل أو أو